Hello There, Guest! Login Register
Advertise Here | Remove Ads

Windows-based Server-side Programming Problem

  • 0 Vote(s) - 0 Average


11-07-2016, 11:44 AM #1
fametixc Offline FFU NEWCOMER FFU NEWCOMER
Posts:1 Threads:1 Joined:Nov 2016 Reputation: 0 Sex Female
I wonder if this is the right place for this? If it isn't, please let me know of the right place and I'll try to have it moved (or a mod could move it). I used server in asphostportal.com

Anyway. I'm having trouble configuring Apache and Wamp on my Windows 10 laptop. I want to do CGI programming with C++, but right now I'm stuck on the configuration step.

When I try to enter "httpd" (without the quotes) into Administrator Command Prompt, I get the following error and warning messages:

C:\Apache24\bin>httpd
AH00112: Warning: DocumentRoot [C:/Apache24/docs/myproject.com] does not exist
AH00112: Warning: DocumentRoot [C:/wamp64/www/myproject.com] does not exist
AH00548: NameVirtualHost has no effect and will be removed in the next release C:/Apache24/conf/httpd.conf:527
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : AH00072: make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : AH00072: make_sock: could not bind to address 0.0.0.0:80
AH00451: no listening sockets available, shutting down
AH00015: Unable to open logs


What should [::]:80 and 0.0.0.0:80 actually be? I tried to make it 8.8.8.8:80 for the Google DNS server on the httpd.conf file on Wamp's directory, but I don't know why it doesn't see that. Should I have downloaded Apache into where my Wamp installation is?

Do I have to do something to my Windows Sockets for this to work, too? I'm guessing this from what it says about socket permissions.

11-07-2016, 06:42 PM #2
NomanProdhan Offline KING OF FFU FFU OWNER
GFX DESIGNER
VIP MEMBER
Posts:680 Threads:224 Joined:Sep 2014 Reputation: 108 Sex Male
Thread moved to right section.
Thanks

[Image: founder.png]

05-23-2017, 11:50 PM #3
shirofuji Offline FFU NEWCOMER FFU NEWCOMER
Posts:9 Threads:2 Joined:May 2017 Reputation: 0 Sex Male
Country: Philippines
[::]:80 and 0.0.0.0:80 basically means listen on port 80 on all network interfaces, 8.8.8.8:80 will never work unless one of your network interface is assigned an IP of 8.8.8.8, so you don't really have to touch that settings. Before starting the httpd server I suggest you check if there is any service or software that is using port 80, probably httpd is already started or another software is using that port. If you have a WAMP installed, try stoping the WAMP service first before starting your httpd, I think WAMP already has a webserver built in that is listening to port 80






Forum Jump:


Users browsing this thread:1 Guest(s)

Advertise Here | Remove Ads